Copy paste a Link to email client (and keep the link)

Hey there :wave:,

I have this issue with Coda for a year now and I decided to (at least try to) solve it.

Let us say that I have a column with a Hyperlink formula. In coda, no worries my link is working.

Now I am copy pasting this element to my email client (Front app), and when I copy paste, I lose my link !
I don’t know how or why this is happening but you have any ideas on how to solve this I’d be glad !

Cheers

2 Likes

There is some work that Coda does with links to offer more display options, like Title, Card, and Embed. If it’s causing trouble for copying the actual text to paste somewhere else, would you be able to create a column that using the same Hyperlink logic, but uses ToText() so it displays as text only and makes it easier to copy?

Hi Ben and thanks for your answer.

Unfortunately, using ToText() makes me loose the link information.

I want to copy the actual link outside Coda (meaning the text, plus the hyperlink).
What I do currently is the following :

  • Copy Text
  • Copy Link
  • Paste both in my email client
  • Select text and press CMD+K to add the link

The only issue being that I do this c.100 times a day so it gets old very quickly.

Can you share an example doc here so we can take a look?

Here is an example :

When I try to copy paste the content of the column “bloc of text”, the hyperlink disappears and I am left with only text.

Would you mind sharing the doc so that “Anyone with the link” can view?

I’ve just done it @BenLee

Hello there @Mathieu_Brun-Picard!
I just copy and pasted the Block of text and the links are pasted with the hyperlink.
I tried the pasting in Word and in Outlook online. So I don’t think it is a problem with Coda.
I tried both in macOS and Windows and it is the same behavior.
What I did noticed is that when you paste via Cmd + ↑ Shift + V in Mac or Ctrl + ↑ Shift + V in Windows it does not paste the hyperlink.

In the last try in the video I used Ctrl + ↑ Shift + V to illustrate this

1 Like

Thanks @Saul_Garcia.

Do you still have the clickable hyperlink or just the formatting ?

Here is my experience in video : (I am using the classic cmd+c and cmd+v, but maybe I should use another shortcut ?)

Yes, it is still clickable

:thinking: That’s strange, have you tried in some other program/app? maybe there is something wrong with the Front app.
If it happens everywhere maybe is some program to manage the clipboard that is causing this, or the OS itself.

I’ve tried it on another mail client (the default mac mail app) and same issue occurs :thinking:

My OS version is Sierra 10.12.6 and I use Alfred as my clipboard manager but I had the issue before using alfred though.

I don’t know really know I can do to solve this issue

@Mathieu_Brun-Picard - if you are using an email program that supports HTML formatting, you shouldnt run into this issue - when you copy contents from coda, we put contents in variety of formats ( plain, HTML and coda format ) - on clipboard

if default mail program on MAC isnt working, I believe preference for “composing” for mail app is set to ‘Plain Text’ instead of rich text. if you change it to “rich text”, it should work.

2 Likes

@Krunal_Sheth, thanks for you answer.

I check with both Front and mac default Mail program.
The former compose email settings are set to HTML and the latter is already set to rich text (and not getting the link when I copy paste).

Maybe I should try something else in Coda (i.e. generating a <a href="..."> tag with the Format() formula) ? Or with the HTML() formula ?

EDIT: One workaround that I fund is generating a markdown [Text][link) and copy-pasting this in front (using the markdown) editor. Moving back to the rich text editor the link is working.

Very strange that the first copy paste do not work and I have to use MD to make it work

@Mathieu_Brun-Picard AFAIK while composing the mail, the hyperlinks are not clickable in default mail program. (and I know that could make you think the link is not copied) - but when you send the email, the receiver does get a clickable link.

1 Like

You are right, I just tried sending an email to myself with link in default mail client and it worked.

Based on your answers, I understand that the issue is coming from Front composer then…

Hi guys,

@Krunal_Sheth was onto something and once I realised that the link stayed in default mac email client I figured that the issue came from Front.

Realizing that markup worked too, I though it was something in my setting that was causing the problem but I could not point the issue.

I contacted the Front Support team that has been super helpful (shout out to you Cori). For anyone out there having the same problem, you just to disable the paste as text settings in your preferences (as shown in screenshot below).

Thanks a lot for your help guys !

3 Likes