Button UI Issues

I’m just wondering how many others are having problems with the new Button UI interface?

For several days now I am having difficulty editing docs because I cannot access Button’s “options” since they changed the interface to separate the information on buttons into 3 groups:

If I have a canvas button, most of the time a scroll bar appears on the button pop up editing and I can open one of the 3 areas and scroll down.

BUT… in a table where I put a button there is no scroll bar on that pop up. So most of the time I cannot see past the Visual information. I can’t see the color choices, nor the icons or anything below that.

I’ve tested several browsers and several docs and I’m seeing this issue across the board for me.

For the Advanced, I can never see anything down there. So I can’t set a disable if formula and I can’t see/edit the button’s name! This is a HUGE issue. I’ve sent a report to Coda support. I’m still waiting on a response on that.

Unfortunately, I don’t have a larger monitor to see if having a larger screen size will allow me to see the hidden info.

Right now I have a 15" laptop and a Surface Pro (what like 11" for those?)

I did hook up a 33" monitor and with the larger monitor because everything now fits on the screen it is accessible. So it’s an issue with smaller monitors needing a scroll bar on the pop up editor.

Hi Susan,

I am on a laptop, with an “average” screen, and it is working for me:

Probably a 15".

Windows and Chrome.


Well that’s even crazier then. I made a Loom video about it. On table buttons it never gives me the scroll bar. But while I was creating the Loom, one time it showed the scroll bars, like the second or third time I edited the button. Then tried 3 or 4 more times and it never would give me the scroll bars again. Crazy. Every doc I have is acting the same way. I’ve logged in with my client’s ID and tried editing their docs and I’ve logged in with my own IDs and tried editing my personal docs. All seeing the same thing, no scroll bar. There’s some other place where the UI changed recently and the scroll bar isn’t working there either but I cannot remember where it is. Once I see it again, I’ll submit another bug report. Coda, has submitted this as a bug. I’m curious how you can see a scroll bar but I cannot. :frowning: I’ll pull Chrome out and see if it has the same issue or not.

I do sometimes have troubles to scroll through the menu of button in a table :pensive: … I generally have to scroll through the whole page to place my table “at the top” to be able to scroll through the problematic button’s menu :woman_shrugging:
But it has been too inconsistent for me to try and investigate any further (old MacBook Pro 15" + Chrome) …
It’s just something I encounter here and there…

Well I pulled up pure Chrome not my usual Edge or WaveBox (chrome based) and same behavior. So doesn’t seem to matter what browser I’m on, I see the same issue.

Bizarre. What I can’t figure out is why one time it actually worked in the middle of recording the video. You’d think it would consistently not work.

Yes, I’ve seen various things that you can’t see the bottom. I usually hop out of the edit window, scroll the page down further and try again and most of the time that works. But for this button issue, that’s not working either. UGH. I kinda love/hate the new layout. Putting the Button’s name way down on the bottom under advanced is annoying. Is it just me? Am I the only one who always names canvas buttons? Something else popped up today that changed and is annoying. I can’t remember exactly but something to do with editing a formula and then it kicks you out and you have to edit again to go change the other things. Might be buttons, might just be column formulas. I’ll have to pay closer attention. I just remember it took me 3 edits to set something up that shouldn’t have because it kept kicking me back to the table when I would change 1 thing. If anyone knows what I’m referring to, please let me know.

Hi @Susan_M_Davis, thanks for sharing this issue! We were able to reproduce this issue on our end and are actively working on a fix for this. We expect this to be resolved in the next several days!

1 Like

Glad to hear it wasn’t just me. @Sam_Harper on several of the column edit boxes if editing from the table by clicking the column’s name I sometimes get a scroll bar on some types and on other types I don’t. Doesn’t seem as consist as the issue on this post but is a problem. Sometimes scrolling on the main window down then going back into the edit box will make the scroll bar appear and sometimes not. I’m hoping this is all releated and that fixing the one issue in the OP will fix all these issues. If not, you might want to look at all the column type edit boxes and see if you can reproduce those as well.

Thank you!!!

I LOVE all the Coda updates and how quickly you guys add great things but once in a while something goes wonky. Glad you guys could reproduce it. That’s half the battle.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.