Display empty "states" in Card View 🤔

#1

Hey,
this is a Screenshot of the Betterment’s Template. The states “in progress” and “in compliance” are visible, even without a card in it.

When I make a Card View, it always hides the groups without any cards in it.

How can I achive, that empty groups are always visible in Card view?

3 Likes

Bug: Pinned Card Columns Not Visible
How to make empty groups appear in a card layout?
#2

You do this in the table view. Go in arrange and manage groups (right click on a group), then you have to pin the groups to make them permanent. Go back to card view.
This has been bugged since a long time (it’s not always working, weird) and I always wanted a good card menu to be able to do this along other parameters instead of having to go back to take view. But it seems it’s actually working quite well now.

1 Like

#3

I’ve never seen that menu before :smiley:

thanks a lot @tomavatars! This should definitely be an option of the card view or even default.

1 Like

#4

Thanks for raising @Daniel_Stieber (and for the quick solve @tomavatars!). Definitely something we need to make clearer in the UI. You’ll also note that this works slightly differently for Lookup and Select List column formats:

Pinning is available for columns not tied to a validated list (as in a Text or Number formatted column). In Lookup / Select List cases it shows up as above.

Hope that helps.

4 Likes

#5

Thanks Evan!

I had it like in your example. These group option buttons were clear than, just the way to get to them wasn‘t.

I guess I‘d expect that whole arrange menu or at least a button to it in the group/sort settings for every table & view.

0 Likes

#6

@evan I just found this options for the lookup and it’s a great way to auto populate a table with new values from another table. But I’m now trying to find a way to filter those values when you choose “show all groups”. Do you have a solution?

0 Likes

#7

@tomavatars do you mean you only want to show a subset of the groups in the table you’ve created? If it’s a lookup column it’s all or nothing – either only showing groups with values, or showing all of them regardless of the filter criteria. That is an interesting case though - UI would get a bit tricky given “show all” would have to be qualified with “that meet the tables filter criteria”.

What’s the use case?

0 Likes

#8

@evan it’s about a voting table.
I have a data table with video games titles.
I have my voting table with groups for game titles as lookup and groups for users. Each title has a link column, a state column (played or to play) and a scale column for one user.
If I don’t show all values, I have to manually push the new titles from the data table with the help of buttons (which is already a great solution).
Using show all allows me to auto populate the voting table but I would like to filter like : show/hide all blank rows in order to see which entries are or are not voted per users.

1 Like

#9

Thanks for the context! I think your current solution is the best option currently but will capture this as feedback for our next round of grouping work.

1 Like

#10

Thanks @evan
I really believe that you can add much wonders to groups!! I feel that it’s only the beginning of it.

0 Likes

#11

image

Hi, my card view is only showing 2 out of 5 columns. There no longer seems to be an option to “Show all groups” or “Show only groups with values”. It seems stuck on “Show only groups with values”.

Very frustrating - it seems like such an obvious requirement - the ability to use cards like a kanban, and change state by dragging into an empty state.

0 Likes

#12

Dear @Richard_Browbek,

Welcome in the community :handshake:,

I created a dummy doc with card view and you are right, the option to “Show all groups” or “Show only groups with values” seems not available anymore.

The only thing that comes in my mind is to create a new view and make it a simple table view, then to add “fake” values to the groups that don’t have content and after that to delete this content.

Hopeful, after that the groups without content will remain visible :crossed_fingers:
It could have been that when the system was updated, your scenario wasn’t foreseen.

Just for curiousity, keep me updated :question:

Success,
//JP

0 Likes

#13

Unfortunately the empty columns seem to forget that they were pinned.

0 Likes