Filter formula to find result on different table. Can anyone tell me what is wrong with this formula?

I’m not great with formulas in Coda yet, as you will see.

I’m not entirely sue of the syntax of formulas yet, but I’ve copied and pasted this one and changed the tables and columns but it doesn’t work. I don’t know why.

CurrentValue.Location=thisRow.Name).[Rad output].First()

hi richard
what about this one:

Location=thisRow.Name).[Rad output].First()

hope it helps, cheers, Christiaan

1 Like

Thanks Christiaan,
copied and pasted it in, but it comes back with "unexpected dot operator " as an error.
And the result is "blank:

I just dont understand why its not working. I think the syntax is right, could it be a column type issue?

well, due the the lack of a sample doc it remains uncertain if we can help you out
what about this one

RadOutputs.Filter(Location.contains(thisRow)).[Rad output].First()

cheers, Christiaan

1 Like

So this one finally worked! Thank you.

I was about to share a sample, but instead changed the table from a lookup, to the source table.
Not sure why that would have any bearing.

But very much appreciate you input.

1 Like

glad it worked @Richard_Shears
would you be so kind to close this thread and to indicate with part of the conversation served as solution, as such others can benefit from it as well.
enjoy your weekend, in my region it is windy and cold :wink:


I’ve liked the specific reply that worked, is that the best way?

Yes, Enjoy your weekend too; its cold and windy where I am too.

the like is appreciated, but I had in mind what you see below, this should be an option for you.

if you cannot find it, the Coda Com Manager might want to clarify to new users how the system works :wink: @steph

Cheers, Christiaan



i second what @Christiaan_Huizer says above.

people should be reminded to flag the solution to their query instead of just ‘liking’ it.

and we should also remind people that they should vote for suggestions instead of just saying they would like it (or ‘+1’) in the comments.

these mechanisms do not appear to be obvious to everyone and the smooth running of this community forum depends on them.

oh and one more hint… how best to share a sample document in the blog with the correct permissions set so we can access them.


1 Like

I’m looking for the tick button to notify the solution, and I don’t seem to have one.
Nor do I have a Vote button?

That’s because this post is tagged as “how to” rather than “ask the community”

By default posts in “how to” don’t expect a solution as that thread is meant to be one where people post educational content showing others “how to”

1 Like

i suggest the category title “how to” is ambigious.

it is intended to mean “here is how to do xxx” for posting how-to instructions

but it it is easy to read it as “how to do what i am trying to do?”

perhaps we need clearer category titles?



@Xyzor_Max , I agree, more precise titles for some people not used to using forums would probably avoid this kind of confusion.

Hey Richard,

Can you please check to see if the “Solution” button is visible for you? I moved this to “Ask the Community” so the option should be available to you now.

Let me know if you have further questions!

1 Like

Hi Steph,
No, the “solution” button isn’t showing up for me.



1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.