Filtering using a pulldown doesn't work on table

I am attempting to add a filter to a table but the filter is not actually removing any of the rows, it just removes any visible data from the “Filtered” rows but leaves an empty row in it’s place.
I have tried this on various other tables and it works fine, but this particular table won’t work.
You can see from the screenshot, I have used both a custom formula filter or the standard filter.
I have set it to filter on a hidden value (not shown) but when the filter is set you can see that the only row should be the first one (it has the grey boxes) but the others should be hidden but they are not. This has worked on all the other tables I have used it on, not sure what is happening here.

CleanShot 2024-02-21 at 09.11.34

This isn’t a filtering issue - it’s a grouping issue.

You have it set so that either:

  • Empty groups should show
  • you have those specific groups pinned so they always show

If you ungrouped the table you’d see those disappear :dotted_line_face:

And if you change the grouping options you’d also see them disappear