Google Calendar Create Event returns Unexpected Error


I had a Google Calendar Create Event button column that saved events to my Google Calendar perfectly fine, but now, regardless of what I’ve tried changing, it always errors when I hit the button.

Here’s a current basic test set up:

I tried:

  • signing in and out of Google via the Pack settings
  • using only a start/end date column or a start date and time column
  • choosing either Use Private Account and a Shared Account option (with Take and View data setting on)
  • created a new doc
  • changed the Action fields to use thisRow.Start Date etc., and just Start Date/End date etc.

I hope it’s something easy and obvious, because it’s super frustrating.

The Quick Add button works.

I appreciate any help. Thanks!

So, there’s a bug with the “isAllDay” field. Entering isAllDay currently returns the error.

If I set the input to true (as described in the docs for CreateEvent)— or true()— it will create the event but it doesn’t respect the span of the start and end dates. It only creates it for the start date as an allday event.

I’ve tried taking off the time, and setting it to only a date field, etc. Everything works except an all day event that spans more than one day.

Argh. :dizzy_face: