Update in Google Calendar

Hi,

when it comes to Task Management, I am a big fan of blocking time in my calendar for the individual tasks in order to not only find but to have time for them.

I mostly doing so on Sunday during my weekly planning session and for that I am first collecting the relevant To Do’s from my ToDo DB for the upcoming week and then my synced calendar from Google in order to have already scheduled appointments and ToDos reflected.
Those I am downloading in to a DB, update date and time and then … I want to sync it back to the Google Calendar. Here starts my problem:

I can easily add a new time slot for a new ToDo with the function CreateEvent (from Google Calendar Pack), however, when I am trying to update an existing time slot, I fail.

I am receiving a message that Coda cannot fetch data form the calendar chosen - this fails whether I am using a formula or action definition for a button:

in both cases it works, if I am not defining the optional calendar at the end of the formula/button.

If I do so, however, it fails with the following error message:

The interesting part is the “%40” - this is apparently automatically replacing the “@” (circled green above)- which makes it impossible for the calendar Pack to find the specific calendar.
I can easily download the calendar items with exactly that address - but I cannot update them with the same address.

I am sure it is easy to fix, but after searching through the internet I still could not find an answer - perhaps somebody has an idea?

Thanks for your help!

Hey @Sven_Schuldt ,
I’ve tried to reproduce the error but everything is working on my end. The %40 is just the urlencoded @ sign, so most likely normal behaviour.

Can you check if the GoogleID is the right id field for the event? And if this event is part of the selected calendar?

What you can also try is to set the calendar dynamic with

Bildschirmfoto 2021-10-20 um 14.20.22

That is the whole formula of my “Update Event” button in a Google Calendar Events table.

Bildschirmfoto 2021-10-20 um 14.26.50

1 Like

Hi @Daniel_Stieber ,

sorry for the late reply - was travelling and a bit busy :wink:
Thanks for sharing your formula.
I have adapted mine to your version and have it works for the original Google calendar but cannot get it up and running for my private Apple Calendar, which I subscribed in the Google Calendar in order to get it into Coda.

After your explanation I am not worried anymore about the “%40” (having been worried proofs, that I am not an expert), however, I still get the “Failed to fetch” message.
I will setup another Apple Calendar and see if the problem remains - if so, I will share that here in the community, I am just a little bit reluctant to do so with my original calendar :wink:

Again, thanks for your help!

Hey @Sven_Schuldt , no worries, glad that it at least helps a bit :smiley:

I’m not familiar how subscribed calendars work within the Google Calendar Pack / API, but it might be possible that this is the problem!

Thanks for sharing your experience and feedback with that!

1 Like