Node v20 bullseye

Following this video, I installed the latest version of Node v20 (bullseye).

I’m installing CLI and getting this warning:

node ➜ /workspaces/coda-packs $ npm install --save @codahq/packs-sdk
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE package: ‘@codahq/packs-sdk@1.6.0’,
npm WARN EBADENGINE required: { node: ‘>=18.0.x <19.0.0’, pnpm: ‘>=8.0.0 <8.6.0’ },
npm WARN EBADENGINE current: { node: ‘v20.8.0’, npm: ‘9.8.1’ }
npm WARN deprecated sinon@15.1.0: 16.1.1

Am I ok to use 20 (bullseye)?

Hi @Brian_Sowards1 - Node 20 should be fine. I think we had previously had an issue with Node 19+ compatibility, but it has since been resolved. We’ll go ahead and update our package.json file to reflect that, but for the time being you should be good to go.

1 Like