Row Details is not always the same if accessed from different areas in Doc


I have a few examples that I can post if need be, but I am running into a situation where if I do not see the same view of a row if I access it in different places in Coda.

I am talking about if I access the row from subtables, floating details when mousing over in lookups, etc. using this control:

One instance is if I access the row from a Subtable. I have tried to duplicate the view I get from the main table in the customization in the Layouts View, but when I click that control in the SubTable, the view is substantially different.

Is there a rule about how rows’ views can differ depending on if they are viewed in subtables, lookups, and other areas?


Could you post some examples of the differences you are seeing?
What do you mean by “substantially different” ? Is it just the layout, or is some data not showing up etc?

You can set separate layouts for the modal row popups on a per table view basis. Here’s a GIF of where that setting is.

@BenLee, OK back in the original post now:

I understand what you’re referring to here:

Here is the row details when I click it from its Master Table, I circled that menu you are referring to, correct?

However here is the same row when viewed if I access it from another area, within a subtable. I also don’t understand why some of the columns are hidden vs. the “original” first view I posted.

Is there a different handling depending on where the row is accessed from, for example if it’s accessed from a subtable or not? If so, how do you control the view in these other access points? Is there a knowledge base article I could refer to so I can have that info handy? This is something that causes me quite a bit of confusion.

I have another doc I’m working on where a row in a similar hierarchy does not show a different details view coming out of a subtable vs. its view from its Master Table. I can post if need be.

Thanks again!

So the same place I showed to edit the layout type, choose “Layout 1”. You’ll see in the first image, you have “Layout 1” and it’s working, then in the second image, you’re set to “Default”.

Embedded tables are an extra layout feature and don’t work in the Default layout.

This isn’t easy to see. It’s a known thing and in the notes for a time when we can sort through other layout issues as well.

@BenLee excellent! Yes of course, makes perfect sense. You can just see in my screenshots that I had the different Layout Types. Very happy about this as I was worried I wouldn’t be able to get the same view due to some limitation possibly in the subtable, but thankfully you’ve just confirmed there is none!

As I get more familiar with Coda I hope to get adept at this type of thing more and more. I’m not sure how I got one of the views on “Default,” and the other on “Layout 1,” but I fixed it in my doc. That also explains the why the other doc has no differences - the layout was set to the same one in each case.

Thanks again!

1 Like