Sort by "Lookup Order" not available when "Show Empty Groups" disabled

I have a table in card view grouped by a column on top. In order for this table to be at all useful, it requires two things:

  1. To be sorted by lookup order.
  2. To have groups with no values be hidden.

I thought that would be straightforward since both abilities are available independently, but for some reason using both together doesn’t work:

Screen Recording 2021-12-06 at 09.28.19 PM

I’d expect that I would be able to use both together. Here is a video w/ audio with more detail about my specific use-case.

1 Like

i must check this out
but my next step would be to have a VIEW for the grouped cards
and then sort the main table using the sort criteria required

does that work?

im traveling a.t.m so cant check this


I don’t think a view will solve the problem in this case. For context:

  • This is being used in an ATS (applicant tracking system)
  • Each opening can define its own custom workflow (new, phone screen, interview, etc.)
  • The card view grouped at top acts like a Trello board – but I want to only show the stages that are applicable to this specific opening.

Ideal Solution: lookup filters would propagate here. I would apply a lookup filter that limited which “workflow stages” each row has access to, and all of the filtered rows have the same subset of “workflow stages” so only those would be displayed.

Backup Solution: I created a placeholder applicant for each workflow stage so that each has at least one applicant. I apply a filter that hides all of the applicants that don’t fit my job which, in turn, should hide all of the stages that don’t have any applicants (since I have sort by lookup order and am hiding empty groups). The problem is that those two don’t work together, so I have to disable the sorting.

Solution to sorting issue: Calculate the workflow stage’s order in the manually ordered table, then add that value to the beginning of the workflow stage’s display column. Then I can sort ascending by name and it works fine, but it’s not ideal.

1 Like