Value for new rows through Lookup column

Hey there, I’ll try to keep this question clear and quick. I’m currently writing a GDD with Coda. I have created a Detail view of a table which represents “Customization sets”. It has stuff such as the set name, which character can equip it, rarity, etc.

I also have a big Table called “Elements” which holds every single part (a customization set is made of multiple parts), the character that can equip it, the rarity and the part’s ID (which is a concatenation of its informations).

Here’s a quick look at how it looks like :

In my Customization Set detail view, I’ve added a Lookup table to display all the parts in the set. In my first screenshot, you can see it’s empty. What I want to do is as follows :

In the Customization Set view (so when I’m in my detail view, second screenshot), I want to be able to add a part to a set (through a button or adding a new row to the lookup table, whichever). This should add the part to the big Parts table + display the added row in the lookup table in Customization sets.
Adding a part should automatically fill the “Character”, “Rarity” and “Set name” columns of the new row (as it can be deducted from which row I’m in inside my Customization Set detail view) so that I would only have to use the dropdown list of the “Part” column to pick which part it concerns.

Problem is, I can’t find a way to do this. Here are the solutions I thought of :

  1. With a button inside my Customization Set view, I can add a row to Parts which has the correct information pre-filled. However, this new row does not appear in my Lookup table in my Customization Set detail view. I have to manually pick the row to make it appear there. That’s one extra step I’d like to avoid. Is there a way to, with the button, first add the row to the Part table (this already works) THEN display that row in the lookup table ?
  2. I tried editing the “Value for new rows” property of my Lookup table. I thought that this way, I could add a new row through the “+” button under the lookup table, it would properly add it to the original Table “Parts” + show the row in my lookup table. That’s all fine and dandy except I have no idea what to put as a formula in “Value for new rows”. I tried everything I could think of but nothing filled the row.

Any idea ? Hope this is not too confused !

Dear @Maxime_Briand,

Great having you in this community.
Would you mind to share a dummy of the doc to be able to understand what you are doing?

Hey, sure ! Here is the page in question :

Hope that’s useful ! Sorry the page is a bit messy as it’s also my testbed, what matters are the Elements table and the Customization Set Detail view

Dear community members,

I had a quick look at the doc of Maxime, but wasn’t able to come with a solution.

It would be very kind of we could give support :handshake:

Thanks for giving it a try ! Still no luck on my side, it would be lovely if someone found a solution!

Hey @Maxime_Briand, I couldn’t find the Parts table you talk about in your OP. Do you mean the Parts column from the Customization Sets layout view?

This column?

If that’s the one, look at this doc: I’ve changed it to display the filtered set of parts for that char. I think the button works as you intended (I haven’t changed the action)

Hey there, thanks for your help! By “the big Parts table”, sorry, I meant the big “Elements” table just above my Customization Set detail view.

However, I just tried the doc you sent and everything seems to be working just like I wanted it to! Clicking the “add part” button properly pops up the entry view, everything is autofilled (except the part type which is normal) and when I validate it gets properly added and shown in both table. That’s excellent! So thanks a lot :slight_smile:

Now the big question is, what did you change haha? Where did you make the change, I can’t see it? I saw this :

but it seems to be something auto-generated from something else, and I can’t find the original change that does this! Could you point me to it? Thanks a lot :slight_smile:

(forgot to mention you, @Dalmo_Mendonca !)

No worries! You were so close. The hint is in the tooltip there below. I changed “the formula in the column Parts of Cusomization Sets”. But to change that you have to set Display mode to Table.

1 Like

Ooh that’s devious! Thanks a lot, I got it now :slight_smile: