The following column is formulaic and cannot have its values modified:

Unexpectedly, the buttons that add tasks to projects stopped working. Before that everything worked without problems. Here is the error:
The following column is formulaic and cannot have its values modified:
What can be the problem?


@Tamerlan_Kagarmanov , you cannot modify a column that holds a formula, remove the formula and it will work again. Coda may sometimes feel like magic, but this is just a matter of configuration.


:smile: I get that, except it was working properly before. It’s like the relay configuration was reversed. Seems like a bug, it’s like that in all of workspace.

Indeed, the relations settings have been reversed.

This happens to me too about few minutes ago. Using Coda on daily basis, this bug really slows my progress down :frowning:

1 Like

Please report it to the support team using the ? in the bottom right of your screen.


I have the same problem. Linked relation columns are no longer allowing automations to edit them. This is a doc-breaking bug.

I have isolated the issue and reproduced it in this doc. Also submitted a bug report.

Hopefully the issue will be fixed soon and the doc above will no longer demonstrate the problem. Edit: The issue has been fixed! So now this doc is appropriately boring.

It would be nice to have some Codan eyes on this @Eric_Koleda Edit: Thanks for checking back in to let us know it’s fixed now


Thanks a lot for the doc and for raising this issue.

I have the same issue. Coda is confusing linked relations with a formulaic column which was not the case days ago.

I have a lot of buttons dependent on modifying linked relations and they are very important in my workspace. Now they don’t work.

This issue is pretty inconvenient and I would really appreciate everything Coda Team could do to solve it as a high priority.


1 Like

In fact, it could be a disaster. Many workspaces are already commissioned and have quite complex architectures and mechanics that utilize button operations. I had to spend a lot of time to fix the bug and restore all the connections.

flagging Eric is not the best way of getting this bug resolved.
you must raise a bug issue with the coda support team using the ? button at the bottom right of your screen.
then it will get the immidiate attention it needs.

this bug should have been detected during the regression testing that should be done before each new release - it is alarming to find this standard devops process has not detected the issue.

and now it is the weekend - so we may have to wait until monday for this to be resolved!

not good

1 Like

I think there is something wrong with your setup - both tables relate to each other.
This makes it impossible to add new items with the button (with the current button setup). If it worked in the past - I think it shouldn’t have.
The Tags column in the Records table can have a calculation, but then you should take the Set values “Tags” out of the button (after all, it will be filled by the calculation).
The Tags table should be maintained manually, although you can also fill it with an automation if the Records.Name entries have a fixed format.
I changed contains() to containstext()
You can see this work in a copy of your doc - just give the automation some time to be triggered.

Sure. As I mentioned, I filed the bug already. Mentioning Eric was just another arrow in the quiver.

1 Like

I wouldn’t have left a report if the problem was my workspace. I test all functions before commissioning a workspace. This problem came out of the blue. Even on the screenshot you can see that records were already added to the database by the button. I.e. for a little less than a month everything worked without problems and was configured as it should be. But suddenly I found out that the settings of the relays had changed exactly the opposite. I am not new to Coda and understand the peculiarities of such functions.

1 Like

Please keep us posted, I would really like to see this working the way you think it should work.
For my docs: I have many relational and/or linked columns, and they are not failing anywhere. But my use is a bit different than your example.
Thanks in advance for placing any update on this topic,
Greetings, Joost

While waiting for responses from other customers myself. Do they have any problems with the buttons that perform transactions with the relations. But I see that I am not the only one who has the same problem. The bugs popped up chaotically in different users.

Another critical bug with the same problem. This is what you could call a catastrophe.

I am sorry to say this, but to the absolute best of my knowledge, formulaic columns could never be set or altered with add or modify rows.

What beats me is that you are certain it used to work - while I am pretty certain I have run into this a long time ago and realized that if a formula is in place, even if you could set it with add or modify rows, it would be useless, since the formula overwrites whatever you would have submitted as a value.

So, why don’t you just skip this column for your button (or automation) action?

I know you said earlier that you are an experienced Coda maker, but I am honestly trying to understand your use case - and so far, I am no getting it.

:smile: Yes I understand, maybe it’s hard for me as a non-native speaker to explain it.
Let me put it this way: take a look at the screenshot. Every relation has this setting:

So what happened is that as if on completely different accounts, in different databases in a chaotic order the system activated this function independently.
And accordingly the relation settings were reversed, which affected some of the interactivity that was created with the buttons.
Why would I lie about it working before. :sweat_smile: I had an executive from one of the companies I did a workspace for in Coda email me today and he had this error three months after going live. And the problem did not occur in other workspaces.

OK, OK. I didn’t accuse you of lying, I just don’t understand.
I am not Coda so I don’t know how this could have possibly happened, but if you know the problem, can’t you just revert to the original settings?
I understand this is not ideal, but Coda is still a work in progress. Some of these changes (at Coda) are not ideal, but things like this have happened before and I am sure that (unfortunately) will happen again.
I am going to look into this in my docs a bit further, because I had noticed some recent changes that I didn’t quit understand, but since they didn’t affected my work, I had parked the task of checking this.

1 Like

I.e., to understand what error I’m talking about try running a simulation. Create two databases, link them through relaying. Add a button that will add a record to the other database upon activation. By default everything will work as it should. Now go to the relation settings as I have shown in the screenshot above and activate the “Switch relation and linked relation” setting and try to activate the button and you will get the same error.
I have already fixed the problem in some workspaces. But what should regular users do if they have the same problem. There is a chance that it will not be obvious to everyone where the problem lies.